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1. Introduction

Zivid Studio is the graphical user interface (GUI) for the Zivid SDK. This allows the user
to explore the functionality of the Zivid Cameras and the capturing of high definition
3D point clouds.

Use Zivid Studio to learn and understand how the majority of functions available in
the Zivid SDK works. This is useful when developing your application. You can:

• Capture point clouds.

• Capture color images.

• Visualize point clouds, color images (2D), depth maps (Z axis), SNR (Signal-to-
Noise-Ratio) maps, and normal maps.

• Analyze and evaluate 3D data quality.

• Determine correct settings and filters for your target objects and scenes.

• Save point clouds and color images to disk.
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2. Control Panel

The control panel is located on the right side in the Zivid Studio GUI. It contains two
sections:

• Camera

• Capture

2.1 Camera

This section is used to scan for, connect to, and disconnect from available cameras.

Camera Function

Scan for connected
cameras

Show all cameras plugged into the PC and list them by model and serial
number.

Connect Connect to the camera selected in the drop-downmenu. Zivid Studio can
connect to a single camera at a time.

Disconnect from
active camera

Disconnect from the active camera.

If multiple cameras are physically connected, they will all appear in this section.
However, Zivid Studio only supports establishing a connection with a single cam-
era at a time. To capture with multiple cameras using Zivid Studio, start another
instance of Zivid Studio.

Note

Firmware update

Each SDK version is matched with camera firmware, and the SDK will make sure that
the camera runs compatible firmware. When Zivid Studio connects to a camera, it will
check whether the camera has matching firmware. If the firmware does not match,
you will get prompted to update firmware on your camera.
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2.2 Capture

This section is used to capture 3D and 2D images. Here you can control and configure
the camera settings. This section has two modes:

• 3D capture

• 2D capture

3D Capture

The 3D capture has two modes:

• Assisted Mode

• Manual Mode

Assisted Mode

Presets

Part of the Zivid SDK is the presets, a set of pre-tuned settings. These presets are
aimed to simplify tuning of the camera parameters and are an alternative to Cap-
ture Assistant. While Capture Assistant tries to optimize exposure settings for any
scene depending on a time budget, presets are specifically tuned for the following
categories:

• Consumer Goods

• Parcels

• Manufacturing

• Inspection

Within each category, you will find various presets. These are separated by scene
complexity, working distance or by the typical type of material property of objects
within that. Different cameras have different presets based on what they are com-
monly used for. Once a preset is selected the ambient light adaptation can be chosen.

Check Zivid Presets on the Knowledge Base to learn more.
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Auto (Scene analysis)

• Specify “Max Capture Time”

• Click “Analyze & Capture”

This triggers the camera to analyze the scene and output the camera settings re-
quired to cover as much of the dynamic range in the scene as possible. Immediately
after this, the camera performs a second capture using these settings.

• The “Capture” button performs a capture with the settings suggested by the
assisted capture, without additional scene analysis.

“Ambient Light Adaptation” is used when ambient light (AC powered) is mixed with
the camera’s projector.

• Select your power grid frequency from the drop-down menu. 60 Hz is typically
used in Japan, Americas, Taiwan, South Korea, and the Philippines. 50 Hz is the
normal in the rest of the world.

Acquisition and filter settings appear at the bottom right corner of the “Capture”
section after camera captures.
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Manual Mode

In the manual mode, users must configure all settings and filters manually.

Capture and Live

• The “Capture” button captures a single acquisition or a multi-acquisition HDR
with the specified settings, which is then displayed.

• The “Live” button triggers continuous captures, which enable you to view the
scene in real-time.

For high dynamic range scenes, it is necessary to use multi-acquisition HDR. In this
mode, the camera captures one image per acquisition. Each image captured uses the
settings configured for the specific acquisition. These images are then automatically
merged into a single, high-quality HDR frame.

Once you select the manual mode, you can click the “Add Acquisition” button to add
additional acquisitions. By default, each new acquisition added uses the settings of
the previous acquisition. You can clone a specific acquisition by clicking on the three
dots next to that acquisition and then on the “Clone” acquisition option. Use the
same menu to reset acquisition settings or delete individual acquisitions. Disable or
enable acquisitions with the checkbox.
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Click the “Capture” button to capture an imagewith the acquisition settings specified;
unchecked acquisitions are ignored by the capture.

You can also use the Assisted mode to get suggested settings, and then switch to
the Manual mode to fine tune these settings manually.

Engine

The Vision Engine is the backbone of the point cloud computation. It controls the
pattern projecting, imaging, and processing of the images of the projected pattern
to generate the final 3D point cloud.

Setting Function

Engine Choose between different pattern projections.

Reset to default Reset the Engine to the default value.

Check Vision Engine on the Knowledge Base to learn more.

Sampling

Setting Function

Color Selectively include or exclude color information in the captured point cloud.

Pixel Choose the light color of the projected patterns and sampled pixels; this affects
the point cloud resolution.

Check Sampling on the Knowledge Base to learn more.

Exposure settings

Setting Function

Exposure Time The duration a single camera image is exposed to light.

Aperture The opening that controls the amount of light to the camera sensor
through the lens.

Brightness The output power (the amount of light) emitted by the LED projector.

Gain The amplification of the signal from the camera sensor.
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To learn how to tune settings check Capturing High Quality Point Clouds on the
Knowledge Base.

Region of Interest

Setting Function

Box Create and configure a box in 3D and remove the points outside the box.

Depth Remove points outside a user-defined depth range.

Check Region Of Interest on the Knowledge Base to learn more.

Filters

Setting Function

Cluster Filter Remove floating points and small isolated clusters from the point cloud.

Noise Filter Remove or correct points where the projected pattern signal-to-noise-ratio is low.

Outlier Filter Remove points if the distance to their neighboring pixels within the small local region
is larger than the threshold specified in mm.

Reflection
Filter

Remove points impacted by reflections and thus erroneous.

Gaussian
Smoothing Perform Gaussian smoothing on the point cloud.

Contrast
Distortion

Corrects and/or removes points affected by blurring in the camera lens.

Hole Filling
Filter

Fill in removed points, by interpolation between the remaining points.
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To learn how to tune filters check Capturing High Quality Point Clouds on the Knowl-
edge Base.

Color

Setting Function

Balance The color temperature of ambient light affects the appearance of the color image.
Adjust blue, green, and red color balance to make color images look natural.

Gamma The output color image can appear too dark. Adjust the brightness of the color
image.

Color Mode Control how the color image is computed. The options are Automatic, ToneMapping,
or UseFirstAcquisition.
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To learn how to tune color settings check Optimizing Color and Color Balance on the
Knowledge Base.

Diagnostics

The Diagnostics setting is used to collect extra diagnostic data from a capture. When
this setting is enabled the additional data will be saved in the .zdf file. It is recom-
mended to only enable it when reporting issues to Zivid’s support team.

Diagnostics increases the capture time, the RAM usage, and the size of the .zdf
file.

Caution

2D Capture

The 2D capture only has a manual mode, where the user configures 2D capture set-
tings manually.

Capture and Live

• The Capture button captures a single acquisition with the specified settings,
which is then displayed.

• The Live button triggers continuous captures, which enables you to view the
scene in real-time.
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Exposure Settings

Setting Function

Exposure Time The duration a single camera image is exposed to light.

Aperture The opening that controls the amount of light to the camera sensor
through the lens.

Brightness The output power (the amount of light) emitted by the LED projector.

Gain The amplification of the signal from the camera sensor.

To learn how to tune color settings check Optimizing Color and Color Balance on the
Knowledge Base.
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3. Available Views

There are five views available at the bottom of the Zivid Studio GUI. These views show
the following features:

• The point cloud

• The color map

• The depth map

• The SNR map

• The normal map

To navigate between views you can either:

• Use the keyboard shortcuts 1 through 5

• Change the viewmanually at the bottomof theGUI by clicking on the thumbnails

• Select the view from the drop-down menu in the top left corner
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3.1 Point Cloud

This view displays the point cloud of the scene after a capture or after loading a ZDF
file.

• Use the left mouse button to rotate the point cloud.

• Use the right mouse button to pan.

• Zoom in or out by rolling the mouse wheel or, if available, by the middle mouse
button followed by dragging the mouse.

Turning color (C & D) and mesh (M) on and off in this view helps evaluate the point
cloud quality. The point size is also adjustable through the drop-down menu at the
top left. Adjusting the point size is for example helpful for inspecting areas where
textures are important.
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3.2 Color

This view displays the color image of the scene after a capture or after loading a ZDF
file.

• Position the mouse pointer over a pixel in the image to get image coordinates,
RGB, and SNR values. The pixel values are displayed in the status bar in the
bottom left corner of the window.

• Zoom in or out by rolling the mouse wheel or, if available, by the middle mouse
button followed by dragging the mouse.

• Use the left mouse button to pan the view.
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3.3 Depth

This view displays the depth image of the scene after a capture or after loading a
ZDF file.

• Position the mouse pointer over a pixel in the image to get image coordinates,
XYZ, and SNR values. The pixel values are displayed in the status bar in the
bottom left corner of the window.

• Use the drop-down menu located at the top left corner of the view to modify
the Z range.

• Use zoom and pan functionalities in the same way as described in the Color
View.

The color scale represents the distance variation along the z-axis from the camera to
the surfaces of the imaged objects.
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3.4 Signal-to-Noise-Ratio

This view displays the SNR map of the scene after a capture or after loading a ZDF
file.

• Position the mouse pointer over a pixel in the image to get image coordinates
and SNR values. The pixel values are displayed in the status bar in the bottom
left corner of the window.

• Use zoom and pan functionalities in the same way as described in the Color
View.

The color scale represents the variation in the SNR values. A pixel found at the higher
end of the color scale represents a point associated with strong signal quality. For
a point associated with a pixel found at the lower end of the color scale the ratio is
more influenced by noise. Hence, these points involves higher uncertainty.

Rev 1.6 - 1/2024 17 zivid.com



 

 

 

3.5 Normals

This view displays the normal map of the scene after a capture or after loading a ZDF
file.

• Position the mouse pointer over a pixel in the image to get image coordinates,
normal coordinates, and SNR values. The pixel values are displayed in the status
bar in the bottom left corner of the window.

• Use zoom and pan functionalities in the same way as described in the Color
View.

The normalmap provides a 2D representation of the surface normals of a scenewhere
RGB color components describe the normal vectors. The relationship between the
normal vectors and the color components are well visualized in the normal map by
the bin walls and floor. This is because all the points on each surface have the normal
vectors pointing more or less in the same direction.
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The color convention of the normal map is negatively aligned with the camera coor-
dinate system. Hence, normal vectors represented by blue pixels point perpendicular
towards the camera. Looking at the normal map, the blue pixels can be seen on the
bin floor. These normals point in the negative direction of the Z-axis of the camera
coordinate system. The status bar in the bottom left corner is then close to [0, 0,
-1]. An example is outlined in the below image. Furthermore, the right bin wall is
dominated by red pixels. These normals are negatively aligned with the X-axis of the
camera coordinate system. This means that the surface has normal vectors pointing
towards the left in the scene. Likewise, the bottom bin wall is colored green since the
normals are pointing upwards in the scene. Hence, the status bar would respectively
read close to [-1, 0, 0] for a red pixel and close to [0, -1, 0] for a green pixel.

As a result, the normal map is useful for seeing planes in the point cloud. The normal
map is also helpful in inspecting surface curvatures, surface textures, and transitions
between objects.
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4. Toolbar

The toolbar is located at the top of the Zivid Studio GUI. It consists of drop-down
menus to handle files, control the GUI, and get information about the Zivid Software.

4.1 Save and Open

Zivid Studio offers various saving options for point clouds, color images, and settings
to disk.

Save/Export Point Cloud

To save the point cloud in file ZDF format:

.zdf is the native Zivid file format that includes point cloud, color image, and
depth image data.

Note

• Click on File → Save

• Navigate to the location where you want to save the point cloud

• Write down the file name

• Click Save

ZDF is the preferred file format for the Zivid Customer Success Team.
Note
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To export to one of our supported point cloud formats, unordered or ordered Polygon
(PLY), ASCII (XYZ), or Point Cloud Data (PCD)1file format:

• Click on File → Export

• Navigate to the location where you want to save the point cloud

• Write down the file name

• Click Save

Open Point Cloud

Opening a point cloud in Zivid Studio is only supported for ZDF file format:

• Click on File → Open

• Navigate to the location of your ZDF file

• Click Open

Drag and drop a ZDF file to load the point cloud to Zivid Studio - added in Zivid
SDK 2.5.

Tip

Save Color Image

You can also save the 2D color image in PNG, BMP, and JPG file format:

• Click on File → Save Color Image

• Navigate to the location where you want to save the color image

• Write down the file name

• Click Save

Export Settings

It is possible to save all settings to disk.

• Click on File → Export Capture Settings

• Navigate to the location where you want to save the settings

• Write down the file name

• Click Save
1PCD is by default exported as unorganized points but can be configured to be exported as organized

points. Check out the Zivid Knowledge Base for tutorial on how to export PCD as organized points.
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Import Settings

To import the settings in Zivid Studio:

• Click on File → Import Capture Settings

• Navigate to the location of your settings file

• Click Open

Drag and drop a YML file to import the settings to Zivid Studio - added in Zivid
SDK 2.5.

Tip

Settings can be loaded using the Zivid SDK as well.

4.2 Tools

Infield Correction

To open the Infield Correction tool:

• Click on Tools → Infield Correction
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Infield Correction functionality overview

• Last correction shows the last date and time an infield correction was written to
the camera.

• Capture & Measure captures to determine the local dimension trueness of the
point cloud where the Zivid calibration board is placed.

• Current Camera Metrics shows the local dimension trueness for the last capture
taken with Capture & Measure, as well as the average and the maximum for all
the captures.

• Current trueness shows the local dimension trueness for the last capture taken
with Capture & Measure.

• Average trueness shows the average of the local dimension trueness errors for
all the captures taken with Capture & Measure so far.

• Maximum trueness shows the maximum of the local dimension trueness errors
for all the captures taken with Capture & Measure so far.

• Expected Post-Correction Metrics shows the estimated post-correction error
within 1σ statistical uncertainty over the working distances the images were cap-
tured at.

• Save Correction to Camera writes to the camera the parameters for improving
the accuracy of the point cloud determined from the captures of the Zivid cali-
bration board taken with Capture & Measure.

• Reset Camera Correction removes any infield correction that has been applied
in previous correct instances. It is not required to do a reset before doing a new
infield correction.
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4.3 Dropdown Menus

File Shortcut Function

Open Ctrl+O Load a ZDF file. .zdf is the native Zivid file format that includes
point cloud, color image, and depth image data.

Save Ctrl+S Save a point cloud, color image, and depth image data to a ZDF
file, the native Zivid file format.

Export Ctrl+E Export a point cloud data to a file in unordered or ordered Polygon
(PLY), ASCII (XYZ), or Point Cloud Data (PCD) file format.

Save Color Image Save a color image to a file in PNG, BMG, or JPG file format.

Import Capture
Settings

Ctrl+Shift+I Load saved capture settings from a file in YML into Zivid Studio.

Export Capture
Settings

Ctrl+Shift+E Save current capture settings from Zivid Studio into a file in YML.

Exit Alt+F4 Exit Zivid Studio.

View Shortcut Function

Histogram H Open the Histogram, a tool for analyzing pixel intensity distribu-
tion on an image.

Information Shif+I
Open the Information panel to display capture information such
as camera model, capture time and settings used. Provides ability
to apply or save settings from previous captured point cloud.

Reset View Backspace Reset the point cloud, color image, and depth image view back to
the default view.

Reset 3D View
when opening files Enable/disable 3D view reset when opening files.

Reset UI Layout Reset the layout of the Zivid Studio window.

Enter / Exit
Full Screen Mode

F11 Toggle between full and regular screen mode.

Tools Function

Infield Correction Open Infield Correction, a maintenance tool designed to verify and
correct the dimension trueness of Zivid cameras.

Help Function

View help online URL to the Zivid Knowledge Base.

Legal Notice Detailed information on Zivid and third-party software licenses.

System Info Information on the system used by the Zivid software.
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5. Quick Reference Index

File Shortcut Function

Open Ctrl+O Load a ZDF file. .zdf is the native Zivid file format that includes
point cloud, color image, and depth image data.

Save Ctrl+S Save a point cloud, color image, and depth image data to a ZDF
file, the native Zivid file format.

Export Ctrl+E Export a point cloud data to a file in unordered or ordered Polygon
(PLY), ASCII (XYZ), or Point Cloud Data (PCD) file format.

Save Color Image Save a color image to a file in PNG, BMG, or JPG file format.

Import Capture
Settings

Ctrl+Shift+I Load saved capture settings from a file in YML into Zivid Studio.

Export Capture
Settings

Ctrl+Shift+E Save current capture settings from Zivid Studio into a file in YML.

Exit Alt+F4 Exit Zivid Studio.

View Shortcut Function

Histogram H Open the Histogram, a tool for analyzing pixel intensity distribu-
tion on an image.

Information Shift+I
Open the Information panel to display capture information such
as camera model, capture time and settings used. Provides ability
to apply or save settings from previous captured point cloud.

Reset View Backspace Reset the point cloud, color image, and depth image view back to
the default view.

Reset 3D View
when opening
files

Enable/disable 3D view reset when opening files.

Reset UI Layout Reset the layout of the Zivid Studio window.

Enter / Exit
Full Screen Mode

F11 Toggle between full and regular screen mode.

Tools Function

Infield Correction Open Infield Correction, a maintenance tool designed to verify and
correct the dimension trueness of Zivid cameras.

Help Function

View help online URL to the Zivid Knowledge Base.

Legal Notice Detailed information on Zivid and third-party software licenses.

System Info Information on the system used by the Zivid software.
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Camera Function

Scan for connected cameras Show all cameras plugged into the PC and list them by model and
serial number.

Connect Connect to the camera selected in the drop-down menu. Zivid
Studio can connect to a single camera at a time.

Disconnect Disconnect from the active camera.

3D Capture Function

Assisted Mode Switch to assisted capture mode.

Please select a preset ...
Opens a list of predefined settings, the last in the list Auto(Scene
Analysis), is the only one that will not always produce the same
settings.

Max Capture Time (seconds) Maximum capture time in seconds for assisted capture.

Ambient Light Adaptation Specify if and towhat ambient light frequency the assisted capture
is to adapt.

Analyze & Capture Analyze the scene using the Capture Assistant and then capture
with the suggested settings.

Capture (Assisted Mode) Capture with the settings suggested by the Capture Assistant.

Manual Mode Switch to manual capture mode.

Capture (Manual Mode)
Trigger a single acquisition or a multi-acquisition HDR with the
settings specified in the checked acquisitions; unchecked acquisi-
tions are ignored.

Live Trigger a continuous capture that allows viewing the scene in real-
time.

Expand all acquisitions Expand the settings on all acquisitions.

Collapse all acquisitions Collapse the settings on all acquisitions.

Reset to default Reset the control panel to the default state.

Vision Engine Function

Engine Choose between different pattern projections.

Reset to default Reset the Engine to the default value.

Sampling Function

Color Selectively include or exclude color information in the captured
point cloud.

Pixel Choose the light color of the projected patterns and sampled pix-
els; this affects the point cloud resolution.
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Acquisition Function

Exposure Time The duration a single camera image is exposed to light.

Aperture The opening that controls the amount of light to the camera sensor
through the lens.

Brightness The output power (the amount of light) emitted by the LED projector.

Gain The amplification of the signal from the camera sensor.

Toggle switch Enable/disable the selected acquisition.

Clone acquisition Add a new acquisition resembling the setting of the selected acqui-
sition.

Delete acquisition Delete the selected acquisition.

Add acquisition Add a new acquisition resembling the setting of the last acquisition.

Reset acquisition to default Reset the selected acquisition settings to default values.

Region of Interest Function

Box Create and configure a box in 3D and remove the points outside the
box.

Depth Remove points outside a user-defined depth range.

Filters Function

Cluster Filter Remove floating points and small isolated clusters from the point
cloud.

Noise Filter Remove or correct points where the projected pattern signal-to-
noise-ratio is low.

Outlier Filter Remove points if the distance to their neighboring pixels within the
small local region is larger than the threshold specified in mm.

Reflection Filter Remove points impacted by reflections and thus erroneous.

Gaussian Smoothing Perform Gaussian smoothing on the point cloud.

Contrast Distortion Corrects and/ or removes points affected by blurring in the camera
lens.

Hole Filling Fill in removed points, by interpolation between the remaining points.

Reset to default Reset the filters to the default state.

Color Function

Blue color balance
The color temperature of ambient light affects the appearance of the
color image. Setting white balance by adjusting blue color balance
makes the color image look natural.

Green color balance
The color temperature of ambient light affects the appearance of the
color image. Setting white balance by adjusting green color balance
makes the color image look natural.

Red color balance
The color temperature of ambient light affects the appearance of the
color image. Setting white balance by adjusting red color balance
makes the color image look natural.

Gamma The output color image can appear too dark. Adjust the brightness
of the color image.

Color Mode Control how the color image is computed. The options are Automatic,
ToneMapping, or UseFirstAcquisition.

Reset to default Reset the blue, green, and red color balance to the default state.
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Shortcut Keyboard Shortcut Function

1 Navigate to 3D View

2 Navigate to Color Image

3 Navigate to Depth Map

4 Navigate to SNR Map

5 Navigate to Normal Map

C Enable/disable Monochrome (Green) point cloud color

D Enable/disable Depth Map point cloud color

M Enable/disable Mesh in point cloud
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6. Support and Troubleshooting

For more information, visit:

support.zivid.com

The Zivid Knowledge Base provides answers for commonly seen issues and ques-
tions related to Zivid products, for both software and hardware. You will also find in
depth articles about our camera technology, best use practices, different types of 3D
imaging methods and structured light, to get a better understanding for how to use
this product.
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7. About Zivid

Zivid is a market-leading provider of 3D machine vision cameras and software for
next generation robotics and industrial automation systems. Its Zivid 2+, Zivid 2, and
Zivid One+ products are regarded as the world's most accurate real-time 3D color
cameras and bring human-like vision to the smart factories and warehouses of Indus-
try 4.0.

To find out more about Zivid, visit:

www.zivid.com

Email
Technical support: customersuccess@zivid.com
Sales: sales@zivid.com
General: info@zivid.com

Phone
Zivid HQ-Oslo, NO | +47 21 02 24 72
Zivid Sales-Stuttgart, DE | +49 151 72 939 674
Zivid Sales-Austin, TX, US | +1 (847) 345-7691
Zivid Sales-Xiamen, CN | +86 139 5012 9074
Zivid Sales-Seoul, KR | +82 10 8984 5350

Zivid
Gjerdrums vei 10A

0484
Oslo, Norway

Rev 1.6 - 1/2024 30 zivid.com

https://www.zivid.com


 

 

 

©04/01/2024, Zivid. All rights reserved. Subject to change without notice.

Rev 1.6 - 1/2024 31 zivid.com


	Introduction
	Control Panel
	Camera
	Firmware update

	Capture
	3D Capture
	2D Capture


	Available Views
	Point Cloud
	Color
	Depth
	Signal-to-Noise-Ratio
	Normals

	Toolbar
	Save and Open
	Save/Export Point Cloud
	Open Point Cloud
	Save Color Image
	Export Settings
	Import Settings

	Tools
	Infield Correction

	Dropdown Menus

	Quick Reference Index
	Support and Troubleshooting
	About Zivid

